1. Événement d'Halloween 2019

    Oserez-vous nous rejoindre pour l'événement d'Halloween 2019 ?
    Cette année, pour Halloween, nous avons transformé l'habituelle série de quêtes des années précédentes en un événement monstrueux à part entière avec de superbes récompenses ! Pour plus de détails, vous pouvez cliquez ici !
    Rejeter la notification
  2. Améliorations de la GcG

    D'importants changements sont prévus concernant la GcG ! Plus d'informations ici !
    Rejeter la notification
  3. Mise à jour 1.163

    Forgiennes et Forgiens,
    La mise à jour 1.163 aura lieu le mercredi 16 octobre. Comme d'habitude, il y aura une courte interruption des serveurs pendant la mise à jour et nous vous prions de nous excuser pour ce petit désagrément.
    Pour une description détaillée des changements à venir, veuillez cliquer ici.
    Rejeter la notification
Rejeter la notification

Navigateur Y aurai t'il un problème Foe/FireFox ?

Discussion dans '[A] Bogues et problèmes' démarrée par shadows29, 13. Sep 2016.

  1. Tharweran

    Tharweran Comte

    Inscription:
    14. Jan 2017
    Messages :
    4.935
    "J'aime" reçus :
    1.120
    Quelle est la version de Firefox que tu utilises, s'il te plait ?
     
  2. LE SIAM

    LE SIAM Biologiste

    Inscription:
    19. Déc 2013
    Messages :
    2.560
    "J'aime" reçus :
    1.388
    la 51.0.1
     
  3. barbu13

    barbu13 Force de frappe

    Inscription:
    16. Juin 2014
    Messages :
    430
    "J'aime" reçus :
    99
    Chrome est bien, sauf pour la GvG, où il est meme un des plus mauvais.
    Moi j'ai abandonné FF.
     
  4. Tharweran

    Tharweran Comte

    Inscription:
    14. Jan 2017
    Messages :
    4.935
    "J'aime" reçus :
    1.120
    On parle bien de la version 32 bits ?
     
  5. LE SIAM

    LE SIAM Biologiste

    Inscription:
    19. Déc 2013
    Messages :
    2.560
    "J'aime" reçus :
    1.388
    oui, plus haut j'ai dit que j'étais sur la 32bits et que ça marché pas, donc je suis passé sur la 64 pour voire et rien donc je suis repartis sur la 32
     
  6. Tharweran

    Tharweran Comte

    Inscription:
    14. Jan 2017
    Messages :
    4.935
    "J'aime" reçus :
    1.120
    Je préférais vérifier car, selon la description que tu fais de ton problème, cela ressemble à ce qui se produit lorsqu'on essaie de lancer le jeu sur un Firefox 64 bits.
    As-tu essayé de désactiver temporairement Avast, le temps de faire un test ? Cela peut être dû à une erreur interne du programme antivirus, sans que FOE soit clairement indiqué comme bloqué dans les paramètres de l'antivirus.
     
  7. LE SIAM

    LE SIAM Biologiste

    Inscription:
    19. Déc 2013
    Messages :
    2.560
    "J'aime" reçus :
    1.388
    j' l'ai désactivé et cela ne change rien
     
  8. thorgull

    thorgull Laborantin

    Inscription:
    18. Oct 2014
    Messages :
    91
    "J'aime" reçus :
    12
    Je confirme après en avoir fait les frais que l'écran noir est lié à l'utilisation de la version 64bits de Firefox (51.0.1). Flash fourni les versions 32 et 64bits de son plugin de navigateur, mais apparemment Firefox_x64 n'arrive pas l'utiliser.
    Pour ceux qui repassent de la version 64bits à 32bits de Firefox, essayez les manipulations suivantes:
    1. Désinstallez Firefox édition 64bits.
    2. Rendez-vous dans C:\Utilisateurs\${USER}\AppData (remplacez USER par votre nom d'utilisateur). Attention AppData est un répertoire caché, pour y accéder il suffit de rajouter le nom dans la barre d'adresse.
    3. Dans AppData, allez dans les trois répertoires Local, LocalLow et Roaming. Supprimez-y le répertoire Mozilla (après en avoir fait une sauvegarde le cas échéant).
    4. Installez et lancez Firefox édition 32bits.
    5. Le cas échéant, accepter si Firefox demande de procéder à un nettoyage du navigateur.

    Si qui que ce soit réussi à utiliser FoE sous Firefox édition 64bits je suis à l'écoute.
     
    JoeBAR085 aime cela.
  9. JoeBAR085

    JoeBAR085 Force de frappe

    Inscription:
    6. Juin 2016
    Messages :
    499
    "J'aime" reçus :
    103
    Merci pour ta combine @thorgull

    Perso j'ai arrêté de batailler avec FF64 depuis longtemps. C'est mon nav principal (genre 50 onglets) en plus, donc lourd de gérer une session FoE avec (à l'époque ou cela fonctionnait encore).
    J'ai plus d'ennui depuis que je passe par IE pour le jeu, pour tous les aspects (pas taper hein :-D)
     
  10. HungMaau

    HungMaau Mousquetaire

    Inscription:
    3. Nov 2014
    Messages :
    239
    "J'aime" reçus :
    8
    pour ff64bits 52.0 :
    dans about:config
    dom.ipc.plugins.asyncdrawing.enabled;true

    sinon ca charge pas (ecran noir)
    par contre ca marche pas de manière stable.
    si FOE est le seul onglet, c mieux. suis en train de tester
    par contre coté consommation mémoire, suis a 700MB de moins que sous chrome.

    Vais essayer le dernier edge, pour rire
     
    balthor et UnknownMind aiment cela.
  11. mystérian II

    mystérian II Forgeron

    Inscription:
    21. Déc 2016
    Messages :
    11
    "J'aime" reçus :
    2
    Bonjour,
    j'ai eu le même problème ... et j'ai trouvé la solution, en tout cas, pour moi.
    J'espère que cela pourra t'aider Le Siam :

    1- Je suis allé dans l'onglet "outils" de firefox
    2- j'ai choisi "modules complémentaires. Cela ouvre une nouvelle page avec, dans la marge, "plugins" qui est sélectionné
    3- dans la liste de plugins, j'ai cliquer sur "plus" dans "shockwave Flash"
    4- cela me donne des infos sur shockwave qui fait apparaître une CASE COCHEE "activer le mode protégé d'adobe flash", que j'ai DECOCHEE.
    5- j'ai relancé FOE et ça a marché.
     
    LadyKisaragi aime cela.
  12. Prom d Exolandia

    Prom d Exolandia Biologiste

    Inscription:
    27. Jan 2017
    Messages :
    2.528
    "J'aime" reçus :
    1.855
    Et encore des ralentissements sous Firefox suite à la MAJ 1.99

    On prend les mêmes et on recommence :(

    Et je précise que ça ne vient pas de Firefox, j'ai le problème avec un pc ou ni Firefox ni Flash n'ont été mis à jour cette semaine et sur un PC avec Firefox et flash en dernière version (même ultra dernière vu que ce sont les versions beta). Le ralentissement vient donc forcément de la mise à jour.

    Il faudrait sérieusement penser à investir dans de vrais développeurs.
     
  13. placid88

    placid88 Président

    Inscription:
    11. Fév 2013
    Messages :
    9.447
    "J'aime" reçus :
    2.913
    ils l'ont fait sauf qu'ils ont optimisés le jeu pour Chrome
     
  14. Naolia

    Naolia Président Équipe Community Manager

    Inscription:
    14. Fév 2014
    Messages :
    8.812
    "J'aime" reçus :
    3.549
    Utilisez simplement la dernière version et non les versions beta.
     
    PiotrG aime cela.
  15. Prom d Exolandia

    Prom d Exolandia Biologiste

    Inscription:
    27. Jan 2017
    Messages :
    2.528
    "J'aime" reçus :
    1.855
    Aujourd'hui j'ai ma ville qui disparait et réapparait :
    https://mon-partage.fr/f/vnv0w0N6/
    Voici la log du debug flash :
    [Starling] Initialization complete.
    [Starling] Display Driver: DirectX11
    Avertissement : un fichier SWF ActionScript 1.0/2.0 a chargé un fichier SWF ActionScript 3.0. Le code du fichier SWF ActionScript 3.0 ne s'exécutera pas.
    Avertissement : un fichier SWF ActionScript 1.0/2.0 a chargé un fichier SWF ActionScript 3.0. Le code du fichier SWF ActionScript 3.0 ne s'exécutera pas.
    Avertissement : Limite d'avertissement atteinte pour 2
    Avertissement :Paramètre secure='true' détecté dans le fichier de régulation de xmlsocket://fr17.forgeofempires.com:843, mais l'hôte fr17.forgeofempires.com n'apparaît pas pour faire référence à l'ordinateur local. Ceci peut poser des problèmes de sécurité. Pour plus d'informations, consultez http://www.adobe.com/go/strict_policy_files_fr.
    Avertissement :Paramètre secure='true' détecté dans le fichier de régulation de xmlsocket://fr17.forgeofempires.com:843, mais l'hôte fr17.forgeofempires.com n'apparaît pas pour faire référence à l'ordinateur local. Ceci peut poser des problèmes de sécurité. Pour plus d'informations, consultez http://www.adobe.com/go/strict_policy_files_fr.
    Avertissement :La balise <allow-http-request-headers-from> non valide est ignorée pour le domaine '*' dans le fichier de régulation présent à xmlsocket://fr17.forgeofempires.com:843
    I DONT KNOW HOW TO HANDLE DER stuff of TYPE 12
    Warning: Injector already has a rule for type "org.robotlegs.core::IReflector", named "".
    If you have overwritten this mapping intentionally you can use "injector.unmap()" prior to your replacement mapping in order to avoid seeing this message.
    Warning: Injector already has a rule for type "org.robotlegs.core::IInjector", named "".
    If you have overwritten this mapping intentionally you can use "injector.unmap()" prior to your replacement mapping in order to avoid seeing this message.
    Warning: Injector already has a rule for type "flash.events::IEventDispatcher", named "".
    If you have overwritten this mapping intentionally you can use "injector.unmap()" prior to your replacement mapping in order to avoid seeing this message.
    ArgumentError: Error #3675: Le format de texture ne correspond pas.
    at flash.display3D.textures::Texture/uploadFromBitmapData()
    at starling.textures::ConcreteTexture/uploadBitmapData()
    at starling.textures::Texture$/fromBitmapData()
    at starling.text::TextField/createRenderedContents()
    at starling.text::TextField/redraw()
    at starling.text::TextField/getBounds()
    at starling.display::DisplayObjectContainer/getBounds()
    at starling.display::Sprite/getBounds()
    at starling.filters::FragmentFilter/calculateBounds()
    at starling.filters::FragmentFilter/renderPasses()
    at starling.filters::FragmentFilter/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.core::Starling/render()
    at starling.core::Starling/nextFrame()
    at starling.core::Starling/onEnterFrame()
    Error: Error #3669: Taille d’entrée incorrecte.
    at flash.display3D::Context3D/configureBackBuffer()
    at Function/http://adobe.com/AS3/2006/builtin::apply()
    at starling.core::Starling/configureBackBuffer()
    at starling.core::Starling/updateViewPort()
    at starling.core::Starling/render()
    at starling.core::Starling/nextFrame()
    at starling.core::Starling/onEnterFrame()
    Error: Error #3669: Taille d’entrée incorrecte.
    at flash.display3D::Context3D/configureBackBuffer()
    at Function/http://adobe.com/AS3/2006/builtin::apply()
    at starling.core::Starling/configureBackBuffer()
    at starling.core::Starling/updateViewPort()
    at starling.core::Starling/render()
    at starling.core::Starling/nextFrame()
    at starling.core::Starling/onEnterFrame()
    ArgumentError: Error #2015: BitmapData non valide.
    at flash.display::BitmapData/ctor()
    at flash.display::BitmapData()
    at starling.text::TextField/renderText()
    at starling.text::TextField/createRenderedContents()
    at starling.text::TextField/redraw()
    at starling.text::TextField/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.core::Starling/render()
    at starling.core::Starling/nextFrame()
    at starling.core::Starling/onEnterFrame()
    ArgumentError: Error #2015: BitmapData non valide.
    at flash.display::BitmapData/ctor()
    at flash.display::BitmapData()
    at starling.text::TextField/renderText()
    at starling.text::TextField/createRenderedContents()
    at starling.text::TextField/redraw()
    at starling.text::TextField/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.core::Starling/render()
    at starling.core::Starling/nextFrame()
    at starling.core::Starling/onEnterFrame()
    ArgumentError: Error #2015: BitmapData non valide.
    at flash.display::BitmapData/ctor()
    at flash.display::BitmapData()
    at starling.text::TextField/renderText()
    at starling.text::TextField/createRenderedContents()
    at starling.text::TextField/redraw()
    at starling.text::TextField/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.core::Starling/render()
    at starling.core::Starling/nextFrame()
    at starling.core::Starling/onEnterFrame()
    ArgumentError: Error #2015: BitmapData non valide.
    at flash.display::BitmapData/ctor()
    at flash.display::BitmapData()
    at starling.text::TextField/renderText()
    at starling.text::TextField/createRenderedContents()
    at starling.text::TextField/redraw()
    at starling.text::TextField/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.display::Sprite/render()
    at starling.display::DisplayObjectContainer/render()
    at starling.core::Starling/render()
    at starling.core::Starling/nextFrame()
    at starling.core::Starling/onEnterFrame()

    Et ma config :
    1.99.1a485f4dc5 (19.04.2017 11:11), Prom d Exolandia (4534743), fr17, fr_FR, WIN 25,0,0,156 DEBUG, Windows 7, Firefox/54.0, 2049x1023, DirectX11 (336 MB VRAM)
     
    Dernière édition: 24. Avr 2017
  16. Tharweran

    Tharweran Comte

    Inscription:
    14. Jan 2017
    Messages :
    4.935
    "J'aime" reçus :
    1.120
    Il n'y a pas d'optimisation mais une différence de prise en charge en fonction des navigateurs.
    @Prom d Exolandia Une version beta pour Flash, une version de développement pour Firefox, ce n'est pas le meilleur moyen de tester une éventuelle incompatibilité logicielle. D'autant plus avec les récentes annonces de Mozilla sur sa volonté d'éliminer Flash de ses plugins pris en charge.
     
  17. Prom d Exolandia

    Prom d Exolandia Biologiste

    Inscription:
    27. Jan 2017
    Messages :
    2.528
    "J'aime" reçus :
    1.855
    Je suis beta-testeur Firefox et une version beta n'est pas une version alpha (je ne suis pas sous Aurora), j'ai juste 3 semaines d'avance sur la version officielle. Avec certes quelques petits bug mais généralement très à la marge.
    Je (re)précise que je joue principalement à FOE avec le couple Firefox beta + Flash normal, j'ai un pc Firefox beta + flash beta avec debug mais ça n'est pas mon pc principal. J'ai également un pc avec firefox officiel + flash normal.
    J'ai le problème sur mes 3 pc (avec un process plugincontainer qui augmente au fil du temps passé sur le jeu, monté à 2Go de RAM hier avec crash du pc, merci Inno) Il y a donc vraisemblablement une grosse fuite mémoire dans FOE et des problèmes sur la gestion du zoom.
    A noter que j'ai pu récupérer un pc avec chrome, 3mn pour afficher mon village... le seul avantage c'est que le jeu ne plante pas (mais peut-on parler d'un avantage ?)

    Je précise que bien entendu je vide cache et autre machins régulièrement.

    A noter que depuis hier soir mon village ne s'affiche plus sur aucune version ffx, écran noir avec au mieux quelques batiments qui s'affichent mais jamais le village en entier.
     
    Dernière édition: 27. Avr 2017
  18. OR73

    OR73 Forgeur d'or

    Inscription:
    20. Juin 2016
    Messages :
    1.321
    "J'aime" reçus :
    4.215
    Bsoir Prom,
    Je n' ai pas vu sur quel OS tu es.
    En tout cas sous Linux ( Fedora et Ubuntu ) nickel en version LTS, et version finale ( FF ).
    Bon faut faire attention une Version Béta en langage Win c' est une Préversion avec envoi d' info quasiment en continue.
    Disparition du Flash ? Ce n' est pas pour tout de suite.
    Il y a encore bien trop de ressources qui utilisent. Pertes financières importantes à s' attendre.
    Je ne crois pas que la politique soit de balancer de l' argent par les fenêtres.
    Mozilla à un chiffre d' affaire important par le développement de navigateurs et de serveurs.
    C' est d' ailleurs ce qui fait leur renommée.
    Bon par contre, je t' invite à lire ceci:
    https://www.nextinpact.com/news/996...hangements-internes-extensions-a-verifier.htm

    Par contre, sur plantage tu peux obtenir des infos à Mozilla.
    Le rapport d' erreur est en leurs mains.
    Si tu es Béta-Testeur tu dois le savoir.
    Cela sert à cela aussi.
    Mais attention, tu vas devoir prouver que ton système est stable avant installation du Log.
    C' est dans les termes du contrat qui te lie à Moz.
    Et je ne parle même pas de ton OS.
    Ils peuvent tout vérifier assez rapidement.

    Il existe une autre possibilité.
    Sur ' Béta ', il n' est pas rare que les greffons ne soit pas compatibles et doivent être retravaillés.
    C' est le cas de FF lorsque l' on passe 3 Versions.
    Dans ce cas un greffon ajouté ne veut pas dire qu' il fonctionne correctement ou déclenche une erreur.
    La bécane peut passer outre. Voilà. A suivre.
     
  19. balthor

    balthor Cueilleur

    Inscription:
    13. Mai 2013
    Messages :
    9
    "J'aime" reçus :
    0
    Merci pour moi cela fonctionne désormais.

    Je suis un PC neuf et je voulais passer à FFx64 et cela fonctionne désormais grâce à toi !
     
  20. Catisfaction54

    Catisfaction54 Ouvrier

    Inscription:
    17. Mar 2017
    Messages :
    35
    "J'aime" reçus :
    6
    Pareil pour moi, problème réglé. ( écran noir )
    Pour firefox 64bits il faut faire dans la barre d'adresse de firefox " about:config " et entrer
    Ensuite dans le volet qui vient de s'ouvrir recherche " dom.ipc.plugins.asyncdrawing.enabled / false " ensuite clique droit puis inverser sur "true"
    Relance le navigateur et le jeu fonctionne.

    La soluce est bonne mais je pense que sur un pc peu puissance ca va ralentir le jeu, avec une config pc puissante ça devrait être crème.
    Bien voir quand même la mise à jour de la carte graphique car si écran noir des fois cela viens du chargement des textures.
    Bien mettre un coup de ccleaner aussi.
    Le mieux étant pour l'instant de rester sur firefox 32 bits le temps que la team trouve peut être quelque chose.

    Pour ceux qui veulent rester sur la 64 bits et qu'il veulent donner un coup de fouet a leur firefox faites exactement ceci :

    network.dns.disableIPv6 => true
    network.http.pipelining => true
    network.http.pipelining.maxrequests => 8
    network.http.proxy.pipelining => true

    Ensuite, nous allons ajouter une nouvelle entrée. Il suffit pour cela de faire un clic doit n'importe où, de choisir Nouvelle puis Valeur numérique(ou nombre entier), de donner le nom " nglayout.initialpaint.delay " à cette nouvelle entrée et lui donner 0 pour valeur.

    Voila j'ai fait le tour


    Merci :)
     
    Dernière édition: 22. Mai 2017

Haut de page