• Événement Estival 2024

    L'événement estival 2024 a débuté ! Préparez vos équipages et embarquez pour une aventure de pirates palpitante au cœur des Caraïbes, du 11 juin au 13 juillet ! Pour plus de détails, vous pouvez cliquer ici !
  • Mise à jour 1.285

    La mise à jour 1.285 aura lieu le mercredi 19 Juin ! Comme d'habitude, il y aura une courte interruption des serveurs pendant la mise à jour et nous vous prions de nous excuser pour ce petit désagrément.
    Pour une description détaillée des changements à venir, veuillez cliquer ici.

Navigateur Décalage des 24h entre le po/mo et la taverne (étapes de reproduction nécessaires)

Statut
N'est pas ouverte pour d'autres réponses.

Deleted User - 4218029

Guest
D'accord mais du coup de ce que j'ai compris le problème viens du PC et de la synchronisation, ça expliquerait que je n'arrive pas à reproduire le bogue, un tel bogue peut-il donc être "réparé" par Innogames ?
Si c'est le cas je le remonte de suite même s'il semblerait que ce ne soit pas la première fois, c'est d'ailleurs pour ça que je me pose la question précédente.
 
Oui la desynchro est moins visible sur app mobile, c'est avant tout un pb navigateur web.
Je pense que les dev sont au courant mais c'est bien de remonter que le "bug" est toujours présent. Ce n'est pas simple à corriger mais ils doivent pouvoir faire un peu mieux
 

seigneur vegeta

Missionnaire
honnêtement je ne le voit pas du tout comme un bug , mais oui c'est déplaisant , et la question semble plutot se dirigé vers la difference de programmation selon les cas (comme la taverne de ce que j'ai compris)
 

Deleted User - 4218029

Guest
Ok en tout cas j'essayerais de le reproduire encore de mon côté, mais pour le moment jamais réussi que ce soit sur Smartphone ou Navigateur.

Je le remonte donc (une nouvelle fois ?) !
 

seigneur vegeta

Missionnaire
laisse la fenêtre du jeux une dizaine d'heur avec des production de 24h les amis pareil et les pillage pareil (incident aussi, laisse en apparaître 5/6)
Le décalage devrais apparaître au minimum sur du 1 h d'attente .
 

Deleted User - 4218029

Guest
laisse la fenêtre du jeux une dizaine d'heur avec des production de 24h les amis pareil et les pillage pareil (incident aussi laisse en apparaître 5/6
Mon jeu est ouvert quasi constament, et j'ai fais ça avant hier avec les pomo sans constater le moindre décalage justement, mais je retente ! ;)
 

Deleted User - 4218029

Guest
En tout cas, c'est pris en compte ! ;) Je déplace donc dans la catégorie des bogues signalées, mais je laisse ouvert et vous tiens au courant des tests que j'entreprends. Ainsi que des informations que j'obtiens vis-à-vis de ce bogue.
 

Gruk

Lancier
Bonsoir,

Je viens rajouter mon petit caillou au grand monument :
Mes tests ont été réalisés depuis le même pc sous win10, avec des versions à jour de chrome et firefox, sur les serveurs fr9, fr10 et zz1, en obtenant les mêmes comportements.

Je retrouve cette désynchronisation comme les autres de manière amplifiée au moment de passer la brosse à po/mo après avoir laissé mon navigateur ouvert pendant les 24 heures séparant les deux sessions de po/mo (un F5 me fait diminuer le compteur d'une quinzaine de minutes habituellement).
Je pars d'une session po/mo régulière de la veille, où je clic le plus rapidement possible sur les boutons d'aide et de succession des joueurs. Après avoir rafraichi l'onglet, si je po/mo mes voisins/amis/guildoux au moment exact où le bouton jaune apparaît, en le faisant suffisamment rapidement, "j'arrive" à retarder l'apparition des boutons jaunes "Aide", et ce décalage se cumule sur les pages suivantes.

De la même façon, si je récolte mes productions de ressources, marchandises ou cacao (colonie aztèque) assez rapidement, je peux créer un décalage de quelques secondes alors que les productions ont été lancées aussi rapidement que possible en utilisant le raccourcis correspondant (d'autant plus facile depuis la mise à jour 1.197).

Un autre exemple est la réalisation de certaines quêtes de colonie qui demandent de disposer d'une quantité de diplomatie fixée. Je fais généralement coïncider ces quêtes avec un changement de bâtiments de production, et j'utilise l'espace ainsi libéré pour construire jusqu'à 40 statues d'adoration (valable pour l'exemple aztèque comme pour les autres colonies). Comme d'habitude, je construit mes statues aussi rapidement que ma souris me le permet. Dans ce cas particulier, la construction des statues n'est que de 30 secondes, ce qui fait que le tooltip indiquant le temps de construction restant est visible pendant toute cette durée. La conclusion est que les dernières statues construites apparaissent alors que le tooltip affiche encore 6 à 7 secondes restantes.

Tout ceci me laisse penser que l'affichage du décompte d'une production est calculé par rapport à une durée transmise par le serveur et ensuite décomptée depuis un cycle d'horloge interne au script de la page internet, qui est soumis à des ralentissements liés au langage de programmation utilisé, alors que la fin effective de la production est signalée par le serveur au moment voulu, et que les décalages qu'on peut observer n'est lié qu'à la différence du mode de calcul.

Si ma théorie s'approche suffisamment de la réalité, une solution serait de conserver le ping de synchronisation émis par le serveur à la fin de la production pour garantir une durée de production exacte, et de calculer les durées restantes affichées dans les tooltips en se basant sur l'horloge du pc client (corrigée par un éventuel décalage horaire mesuré au moment du lancement de la production).
 

Deleted User - 4218029

Guest
Ben moi j'ai essayé et ce matin quand je me suis levé le jeu était fermé à cause de la MaJ ! Du coup je réessaye ! :p

EDIT : J'ai finis par reussir à avoir un décalage de 7 minutes !
 
Dernière édition par un modérateur :

Doudo II

Explorateur
D'accord mais du coup de ce que j'ai compris le problème viens du PC et de la synchronisation, ça expliquerait que je n'arrive pas à reproduire le bogue, un tel bogue peut-il donc être "réparé" par Innogames ?

Un tel décalage peut avoir jusqu'à trois origines : le serveur (donc Inno), le FAI et/ou l'appareil utilisé. (Enfin, plutôt quatre si on compte la personne derrière l'appareil ^^)


Ce décalage concerne TOUS les aspects du jeu, pas seulement les décalages POMO et tavernes (qui plus est apparaissent parfois pleines alors qu'elles ne le sont pas), et ce chez un grand nombre de joueurs (voire tous ?). On peut donc être sûr à 99.99% que le décalage provient en partie d'Inno.

Pour exemple déjà constaté de mon côté des décalages concernant :
- les récoltes (colonies incluses);
- les constructions dans la cité ou les colonies (surtout les bâtiments à 5sec ou 30sec, voir le post de @Gruk);
- l'exploration de nouvelles provinces ou de gisements sur la map;
- la construction de bâtiments sur le CdB (dans le doute, toujours faire un ctrl+F5 quand un camp se termine ou est diamsé, ça évite les mauvaises surprises sur les premiers combats);
- les enchères chez l'antiquaire (rien de méchant, mais lorsque l'on n'a pas fait de refresh depuis longtemps, on peut voir régulièrement deux secondes passer au lieu d'une);
et j'en oublie probablement...


Cependant, il s'agit chez moi d'un décalage de quelques secondes, jamais plus de 10, et un p'tit coup de ctrl+F5 règle tous ces problèmes :D (Je ne parle pas de la construction des bâtiments à 5sec ou 30sec, ça c'est un réel problème à régler de la part d'Inno).

En revanche, avoir un décalage important après une journée sans refresh (toujours ctrl+F5, ça fait toujours du bien héhé ^^) est tout à fait "normal".
Donc le décalage provient en grande partie de la façon d'utiliser son appareil (sans vilain jeu de mot hein), et étant donné l'utilisation habituelle des tablettes et smartphones, ce décalage est presque invisible sur ce type de support car le jeu est régulièrement relancé. Sur PC c'est autre chose, ça ne se fait pas tout seul, il faut prendre le réflexe du refresh (ou le refresh reflex, classe non ?) car il est facile de laisser un onglet ouvert toute la journée et donc voir un décalage s'insérer petit à petit.

Si quelqu'un est confronté à un décalage aussi important que mentionné ici, soit 10-15min, cela provient probablement de votre appareil, votre façon de gérer votre appareil, et/ou votre FAI.


Voilà pour ma contribution à ce sujet, j'ai peut-être dit des énormités, à vous les studios ! :D
 

Harley D

Forgeur d'or
En 2h de connexion, j'ai déjà 6 minutes d'écart :
captu218.png


Ce que je ne comprends pas c'est pourquoi le jeu arrive à déterminer 2 temps différents et pourquoi il ne mets pas celui de la barre sociale (en bas) à jour une fois celui de l'historique affiché !
 

DeletedUser

Guest
Bonsoir
Surement que cela à déjà été évoqué mais je n'ai point trouvé
Voilà j'ai l'habitude (suis pas le seul je pense) à cliquer dans la barre sociale des amis sur aide et sur visiter la taverne en même temps (dans la seconde)
Mais normalement le lendemain le joueur (bien sur s'il a vidé sa taverne) devrait présenter le bouton aide et la chaise vide en même temps (à peu près)
Mais diantre la chose ne se fait point
Normal je ne crois pas
Quelqu'un d'autre l'a constaté ?
Chez moi j'ai des différences de 15 mn environ
Pas grave en soi
 

Fichiers joints

  • Temps.png
    Temps.png
    215,8 KB · Affichages : 8

DeletedUser

Guest
Bonsoir
Merci
Donc cela serait du au temps de jeu
Il faut quitter le jeu toute les heures
Pourtant mon ordi redémarre 4 à 5 fois par jour (c'est un autre problème) et j'ai cet écart
Et pourquoi pas les 2 timer ne se décalent pas ?
Il n'y a que celle pour le polissage motivation
 

L.P.M.

Modérateur
Membre de l'équipe
Modérateur
Bonsoir,
un décalage inverse ayant été mis en place sur les po/mo auto afin de contrebalancer d'éventuelles latences, ce bogue est considéré comme corrigé ; j'archive donc cette discussion.

N'hésitez pas à me contacter en MP pour toute remarque !
 
Statut
N'est pas ouverte pour d'autres réponses.
Haut